2D Parametric Design

In this chapter, you learn about the benefits and characteristics of creating parametric 2D geometry and how various types of dynamic constraints can be assigned to geometry enabling a greater amount of flexibility when editing your design. You learn how to apply geometric and dimensional constraint parameters to stabilize geometry making it more predictable.

With the techniques that you learn in this chapter, you will see how using parametric design can be used to create 2D views of a part or to control the size of the appliances for a room layout. When you assign parameters and relationships to geometry, you in effect make editing or adjusting your design quick and easy.

Objectives

After completing this chapter, you will be able to:

- Describe the characteristics and benefits of designing using parametrics.
- Use geometric constraints to establish relationships between drawn objects.
- Apply dimensional constraints to 2D geometry.
- Use geometric and dimensional constraints to create 2D views of a component.
- Use parametric tools and techniques in a floor plan.
Lesson: Parametric Design

This lesson describes the characteristics of parametric geometry and the overall process of creating designs that utilize the concepts and technology.

Familiarity with the basic characteristics of parametric design simplifies the process of learning and applying the tools to create such geometry.

Objectives

After completing this lesson, you will be able to:

- Describe the characteristics of a parametric design.
- Identify guidelines for capturing design intent.
- State the general workflow for creating parametric designs.
About Parametric Design

You can create and edit 2D geometry efficiently with parametric designs, which are controlled primarily by geometric and dimensional constraints.

A typical parametric design is shown in the following illustration, consisting of 2D geometry with dimensional and geometric constraints. Not all geometric constraints are currently being shown.

Definition of Parametric 2D Designs

A parametric 2D design is a set of drawing objects that contains only the 2D geometry that is controlled and driven by geometric relationships and dimensional values. With a parametric 2D design, you can change a value of a dimensional constraint, and the geometry adjusts according to that value and any existing geometric constraints.
Example of Parametric 2D Design

In the following illustration, a parametric 2D design is shown displaying both geometric and dimensional constraints. When the dimensional constraint value is modified, the geometry updates to reflect the new value while maintaining all of the existing constraints.

Capturing Design Intent

Regardless of the type of design that you are creating, you should always aim to capture the intent of the design as early in the process as possible. It is common for a design to change as a result of inherent design problems or future revisions. The ability to capture design intent makes these potential changes much easier to implement.
Design intent has been captured in the following illustration by using a formula to calculate the center hole size (1) based on the length of one side of the construction polygon (2).

**About Capturing Design Intent**

When you capture your design intent, you add intelligence to your design. This intelligence can exist in several different forms. It can reside in a simple geometric constraint that forces two lines to be parallel or two circles to be concentric. Intelligence can also reside in dimensional constraints that force a feature’s dimension to remain constant or that enable the dimension to change based on a built-in formula.

Just as each design is unique, so is the design intent. Capturing this intent is a process in which you match the design intent with a feature or capability that makes it possible to create the design in the most efficient way while enabling you the maximum flexibility in making changes.

In the following illustration, different examples of design intent are shown being captured at the earliest stage of the design. The constraint bars show geometric constraints that have been applied to the geometry.
Constraint bars display geometric constraints that are applied to the geometry. Each icon illustrates a specific type of geometric constraint that has been applied to the sketch, and as a result captures a portion of the design intent. For example, the right-most icon on the top toolbar indicates that a tangent constraint exists between the top horizontal line and the arc on the right side of the sketch.

Coincident constraints are displayed by a blue dot at the coincident point between two segments.

Dimensional constraints are applied to the geometry. These types of constraints capture design intent by defining the size of objects in the sketch.

Guidelines for Capturing Design Intent
Consider the following guidelines when you begin a new design. Each of the following points indicates an area in which design intent can be captured.

- Identify geometric relationships. For example, a geometry's length may be directly related to its own width, or the width or length of other geometry.
- Identify areas of the design that may be prone to change as a result of design problems or revisions.
- Identify areas of symmetry or areas where features are duplicated or patterned.

Once you have identified the potential ways to capture your design intent, you can then match that intent with a specific parametric command or capability.
Example of a Part Design Capturing Design Intent

A simple parametric design of a plastic indexer is shown in the following illustrations. Each one reflects how a specific guideline of the design intent is captured and implemented into the design with a parametric feature.

Capturing Geometric Relationships in Design Intent

Design intent for the indexer part dictates that the inside diameter (1) should be equal to 1/4th the outside diameter (2) in the following illustration. The design intent has been captured with the use of a simple formula in the dimension parameter.

1. Inside diameter is determined by a formula equal to 1/4th the outside diameter.
2. Outside diameter of the indexer part.
Capturing Design Intent for Features That Are Prone to Change

Design intent has been captured to enable potential design changes in the following illustration. The slot width can change by simply changing the rad1 dimensional parameter (1). When this occurs, equal geometric constraints (2) cause the radii of all other slots to update as well.

1. Changing the rad1 dimensional parameter causes the slot width to change as a result of the tangent geometric constraint.
2. The Equal geometric constraint applied to the slot features causes all of the arcs to update when the rad1 dimensional parameter is changed.
Capturing Symmetry in Design Intent

Design intent for symmetry has been captured in the part design in the following illustration with a symmetric constraint. In this example the slots are kept symmetric about the center of the part by applying symmetric constraints, (1) and (2), to slot edges and a construction line (3) in the middle of the part.

1. Symmetric constraint applied to slot edges.
2. Symmetric constraint applied to slot edges.
3. The line of symmetry for symmetric constraints (1).
4. The line of symmetry for symmetric constraints (2).
Creating Parametric Designs

The overall process for creating parametric geometry is very flexible compared with traditional non-parametric or more rigid types of design processes. This flexibility enables you to concentrate on your digital prototype, its design intent, and the essential design features.

In the following illustration, what started out as simple line, arcs, and circles, is transformed into fully parametric and synchronized front and side views. If parameters are changed in the front view, the side view geometry updates to reflect those changes.

**Process: Creating a 2D Parametric Design**

The following steps provide an overview of the process for creating a 2D parametric design.

1. Create the initial 2D design by using standard creation and editing techniques.
2. Capture the design intent by applying geometric and dimensional constraints.

3. If applicable, create additional geometry, such as views, with dimensional and geometric constraints.

**Parametric Design Considerations**

When creating a parametric drawing, try to determine the basic building blocks of the design, that is, how can it be designed and built in stages. Also determine which aspects of the design are the most critical. Create those aspects first in the order of their importance and relationship.

Parametric design in AutoCAD is available only for 2D geometry. When geometry that contains geometric and/or dimensional constraints is used to create a 3D model, all of the constraints are removed.
Exercise: Create a Parametric Design - Architectural

In this exercise, you create a ceiling light and constrain it to the midpoints of walls. You also modify constrained objects and observe their behavior.

1. Open `I_Floor_Plan_PD.dwg` or `M_Floor_Plan_PD.dwg`.

2. Use the Circle command to place a circular light in the top right of the room approximately the size and location as shown.

3. Constrain the light to the center of the room horizontally:
   - On the Parametric tab, click Geometric panel > Horizontal.

4. Continue with the constraint selections:
   - Right-click anywhere in the graphics area. Click 2Points.
   - Click the midpoint of the left interior wall (1).
   - Click the centerpoint of the light (2).
   
   The light moves in line with the center of the left interior wall.
5. Constrain the light to the center of the room vertically:
   ■ On the Parametric tab, click Geometric panel > Vertical.

6. Continue with the constraint selections:
   ■ Right-click anywhere in the graphics area. Click 2Points.
   ■ Click the midpoint of the top interior wall (1).
   ■ Click the centerpoint of the light (2).
   The light moves in line with the center of the top interior wall.

7. Observe the geometric constraints. To hide the constraint bars:
   On the Parametric tab, click Geometric panel > Hide All.

8. Modify the room size:
   ■ On the Home tab, click Modify panel > Stretch.
   ■ Use a crossing selection as shown.
   ■ Stretch the selection 2' (1200) to the right.
9. Observe that the light remains centered on the top interior wall.

10. Review geometric constraints:
- Zoom to display the right side of the closets.
- On the Parametric tab, click Geometric panel > Show All. This will cause all geometric constraints to be displayed.
- Place your cursor over the collinear constraint on the top closet as shown.
- Observe that the end line is collinear with the end line of the lower closet.

11. Using the Stretch command, stretch the end wall of the top closet only, to the left 1’ (300) as shown. Observe that the end line of the closet below also moves because of the collinear constraint.

12. Adjust the display:
- On the Parametric tab, click Geometric panel > Hide All.
- Zoom to the drawing extents.
- On the Parametric tab, click Dimensional panel > Show Dynamic Constraints. This will cause the dimensional constraints to be displayed.
- Notice that the dimensional parameter d1 is equal to 3-1/2” (116) and that all other dimensional parameters are equal to d1.
13. Change the value for parameter d1:
   - Click dimension parameter d1.
   - Right-click anywhere in the graphics area. Click Edit Constraint.
   - Enter 8 (215). Press ENTER.
   - Notice that all wall thicknesses are 8 (215).

14. On the Parametric tab, click Dimensional panel > Show Dynamic Constraints. The constraints are no longer displayed.

15. Close all files. Do not save.
Exercise: Create a Parametric Design - Mechanical

In this exercise, you add a hole to an impeller and constrain it to the middle of the part. You also modify constrained objects and observe their behavior.

The completed exercise

Completing the Exercise
To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click 
Chapter 1: 2D Parametric Design: Click
Exercise: Creating a Parametric Design - Mechanical.

1. Open Parametric_Impeller.dwg.
2. Use the Circle tool to place a hole near the center of the impeller approximately the size and location as shown.
3. Constrain the hole to the center of the impeller:
   - On the Parametric tab, click Geometric panel > Coincident.
4. Continue with the constraint selections:
   - For the first point, select the circle, the center point of the circle will be highlighted (1).
   - For the second point, select near the end of one of the dotted lines (2).

The circle will move to the center of the impeller.
5. Display all of the geometric constraints:
   - On the Parametric tab, click Geometric panel > Show All.
   - Take note of the geometric constraints.
   - On the Parametric tab, click Geometric panel > Hide All to remove the constraints from the display.

6. Modify the end radius using grips:
   - Select the top arc of the impeller.
   - Select the up arrow.
   - Grip stretch the selection up as shown.

7. Observe that all 6 point radii are changed. Tangency and symmetry is maintained.

8. Turn Dynamic Constraint display on and set the dimension name format:
   - Click the Parametric tab.
   - If the Show Dynamic Constraints icon is not highlighted, click Show Dynamic Constraints.
   - Right-click anywhere in the graphics area, click Parametric > Dimension Name Format > Name and Expression

9. Add a radial dimension:
   - On the Parametric tab, click Dimensional panel > Radial.
10. Continue to add a radial dimension:
   - Click the top outside radius.
   - Place the parametric dimension as shown.
   - For Radius, enter 2.50. Press ENTER.

   Notice how all of the outer arcs change. This occurs because of the equal constraints. The integrity of the shape is maintained by the combination of equal constraints and the construction geometry.

11. Close all files. Do not save.
Lesson: Geometric Constraints

This lesson describes geometric constraints and how to apply them to 2D geometry. You use geometric constraints to control 2D geometry. For example, a vertical constraint applied to a line segment forces that line segment to be vertical. A tangent constraint added to an arc forces that arc to remain tangent to the geometry that has been constrained.

Geometric constraints represent the foundation of all parametric design. Using these objects, you can capture your design intent and force the geometry to follow the rules set by each constraint.

In the following illustration, geometric constraints have been added to the geometry. Each constraint forces the geometry to behave a certain way in relation to other geometry or in relation to the coordinate system.

Objectives

After completing this lesson, you will be able to:

- Describe geometric constraints and their effects on geometry.
- Apply geometric constraints to existing geometry.
- View and delete constraints using the Show Constraints command.
- State key guidelines for successful constraining.
About Geometric Constraints

Several different types of constraints exist, each with a specific capability and purpose. The constraint that you choose depends largely on the design intent.

As you continue to develop the design, you apply constraints to properly stabilize the geometry.

The effects of constraints on the geometry are shown in the following illustration. The geometry on the left was drawn inaccurately on purpose to demonstrate how applying constraints affects geometry. The geometry on the right is the result of adding additional constraints such as perpendicular, parallel, and colinear. In this example, geometric constraints ensure symmetry even without the use of dimensions.

2D Constraints Only

Parametric constraints can be used only on 2D geometry. If the constrained objects are used to create a 3D solid or surface, all constraints are permanently removed.
**Definition of Geometric Constraints**

Geometric constraints stabilize drawn geometry by placing limits on how the geometry can change when you attempt to drag or dimension it. For example, if a horizontal constraint is applied to a line, that line is forced to be horizontal at all times.

In the following illustration, the circle on the right is being resized. Tangent constraints have been applied to the lines. As the circle is resized, the lines remain tangent to both circles.

**Constraint Types**

You can use the following constraint types to constrain your geometry.

<table>
<thead>
<tr>
<th>Constraint</th>
<th>Description</th>
<th>Before Constraint</th>
<th>After Constraint</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tangent:</td>
<td>Use to make selected elements tangent to one another.</td>
<td><img src="image" alt="Before Tangent" /></td>
<td><img src="image" alt="After Tangent" /></td>
</tr>
<tr>
<td>Perpendicular:</td>
<td>Use to make selected elements perpendicular to one another.</td>
<td><img src="image" alt="Before Perpendicular" /></td>
<td><img src="image" alt="After Perpendicular" /></td>
</tr>
<tr>
<td>Parallel:</td>
<td>Use to make selected elements parallel to one another.</td>
<td><img src="image" alt="Before Parallel" /></td>
<td><img src="image" alt="After Parallel" /></td>
</tr>
<tr>
<td>Coincident:</td>
<td>Use to make two points exist at the same point location.</td>
<td><img src="image" alt="Before Coincident" /></td>
<td><img src="image" alt="After Coincident" /></td>
</tr>
<tr>
<td>Constraint</td>
<td>Description</td>
<td>Before Constraint</td>
<td>After Constraint</td>
</tr>
<tr>
<td>------------</td>
<td>-------------</td>
<td>-------------------</td>
<td>------------------</td>
</tr>
<tr>
<td><img src="image" alt="Concentric" /></td>
<td><strong>Concentric:</strong> Use to force two arcs, circles, or ellipses to share the same center point.</td>
<td><img src="image" alt="Before Concentric" /></td>
<td><img src="image" alt="After Concentric" /></td>
</tr>
<tr>
<td><img src="image" alt="Colinear" /></td>
<td><strong>Colinear:</strong> Use to force two lines or ellipse axes to lie on the same line.</td>
<td><img src="image" alt="Before Colinear" /></td>
<td><img src="image" alt="After Colinear" /></td>
</tr>
<tr>
<td><img src="image" alt="Horizontal" /></td>
<td><strong>Horizontal:</strong> Use to force the element to be parallel to the X axis of the current coordinate system.</td>
<td><img src="image" alt="Before Horizontal" /></td>
<td><img src="image" alt="After Horizontal" /></td>
</tr>
<tr>
<td><img src="image" alt="Vertical" /></td>
<td><strong>Vertical:</strong> Use to force the element to be parallel to the Y axis of the current coordinate system.</td>
<td><img src="image" alt="Before Vertical" /></td>
<td><img src="image" alt="After Vertical" /></td>
</tr>
<tr>
<td><img src="image" alt="Equal" /></td>
<td><strong>Equal:</strong> Use to force two elements to be of the same length. In the case of arcs or circles, the radius becomes equal.</td>
<td><img src="image" alt="Before Equal" /></td>
<td><img src="image" alt="After Equal" /></td>
</tr>
<tr>
<td><img src="image" alt="Fix" /></td>
<td><strong>Fix:</strong> Use to cause an element to be fixed in location to the current coordinate system.</td>
<td><img src="image" alt="Before Fix" /></td>
<td><img src="image" alt="After Fix" /></td>
</tr>
<tr>
<td><img src="image" alt="Symmetric" /></td>
<td><strong>Symmetric:</strong> Use to cause the elements to be symmetrically constrained about a line.</td>
<td><img src="image" alt="Before Symmetric" /></td>
<td><img src="image" alt="After Symmetric" /></td>
</tr>
<tr>
<td><img src="image" alt="Smooth" /></td>
<td><strong>Smooth:</strong> Use to cause a curvature continuous condition (G2) between a spline and another curve, line, arc, or spline.</td>
<td><img src="image" alt="Before Smooth" /></td>
<td><img src="image" alt="After Smooth" /></td>
</tr>
</tbody>
</table>
Horizontal Constraint Example

In the following illustration, the application of a horizontal constraint is shown. The two circles are constrained to the endpoints of the line. The design intent requires that these two circles remain aligned. After the horizontal constraint is applied to the line, the line updates and the circle on the right side moves with the line.

Applying Geometric Constraints

Each type of constraint can be applied to certain types of geometry and in certain situations. Some constraints, such as perpendicular, are relational constraints and must be applied to two objects in the geometry. A relational constraint defines a geometric relationship between two objects. Other constraints, such as vertical, can be applied to a single object or two points.

Access

Geometric Constraints

Ribbon: Parametric tab > Geometric panel > Coincident/Collinear/Concentric/Fix/Parallel/Perpendicular/Horizontal/Vertical/Tangent/Smooth/Symmetric/Equal
AutoConstrain Settings

You can adjust the settings that determine how constraints are automatically applied on the AutoConstrain tab of the Constraint Settings dialog box. The Constraint Settings dialog box enables you to set the priority for applying automatic constraint types, turn specific constraint types off or on, adjust rules for tangent and perpendicular constraints, and set tolerance values for distances and angle.

When applying constraints using the AutoConstrain command, if the results differ from what you expected, you should make adjustments to the settings in this dialog box and then reapply them.

Command Access

Constraint Settings

Command Line: CONSTRAINTSETTINGS
Ribbon: Parametric tab > Geometric panel > Arrow
The Priority column lists the order in which constraint types are applied when you use the AutoConstrain command.

Green check marks indicate the constraint will be evaluated and applied for valid conditions. White check marks indicate the constraint will not be applied.

Use the Move Up and Move Down buttons to control the priority of constraint types.

When selected, the tangent constraint is only applied when the objects share an intersection point.

When selected, the perpendicular constraint is only applied when objects share an intersection point.

Enter tolerance values for distances across open points. If there is a gap between two endpoints and that gap is smaller than the distance entered, the endpoints will be made coincident thereby closing the gap.

Enter an angle tolerance to determine whether constraints will be applied.
**Procedure: Applying Automatic Constraints**

The following steps give an overview for automatically applying constraints.

1. On the ribbon, click Parametric tab > Geometric panel > AutoConstrain. Select the geometry that you want to apply constraints to.

2. Constraints are applied and the geometry updates to reflect the constraint conditions.

**Procedure: Applying a Horizontal Constraint**

The following steps give an overview for applying a horizontal constraint.

1. On the ribbon, click Parametric tab > Geometric panel > Horizontal. Select the geometry to apply the horizontal constraint.
2. The geometry is updated to reflect the new constraint condition.

Procedure: Applying an Equal Constraint

The following steps give an overview for applying an equal constraint to two circles.

1. On the ribbon, click Parametric tab > Geometric panel > Equal.

2. Select the circle, line, or arc to which you want to apply the equal constraint.

3. The selected geometry is now constrained to be equal in size.
Procedure: Applying a Symmetrical Constraint

The following steps give an overview for applying a symmetrical constraint.

1. On the ribbon, click Parametric tab > Geometric panel > Symmetrical. Select the first object to constrain.

2. Select the second object for the constraint.

3. Select the object to be used for symmetry.
4. The selected objects become symmetric.

5. Repeat the process to continue adding constraints.
6. The symmetrical constraint is complete.

Analyzing Degrees of Freedom

Degrees of freedom refer to the directions an object is able to move without restriction. When you constrain objects in your drawing with geometric constraints, you are reducing the available degrees of freedom on each object. For example, when you apply a horizontal constraint to a line, you have effectively removed the ability for the line's angle to change. It must remain horizontal at all times.

When constraining geometry, it is often necessary to analyze the remaining degrees of freedom to determine where additional constraints are required or where existing constraints need to be removed.

When geometry is constrained, you can analyze the degrees of freedom by using standard grip editing techniques to move the geometry. While doing so, all geometric constraints are honored, thereby allowing the geometry to move only based on the available degrees of freedom. You can temporarily relax the degrees of freedom on the selected object by pressing the CTRL key. After the edit is completed, the constraints are reactivated.
Showing and Deleting Constraints

As you create and constrain your geometry, you may need to view and possibly delete some constraints. Using the Show Constraints command, you can view the constraints that are applied to the selected geometry and if necessary, select the constraint(s) and delete them. You can also use the Show All Constraints tool to display the constraints on all of the objects in your drawing.

Command Access

Show and Hide Constraints

Command Line: CONSTRAINTBAR > Showall/Hideall
Ribbon: Parametric tab > Geometric panel > Show/Show All/Hide All

Constraint Settings

Command Line: CONSTRAINTSETTINGS
Ribbon: Parametric tab > Geometric panel > Arrow
Constraint Dialog Box: Geometric Tab

You can adjust whether or not constraints appear on constraint bars when you use the Show or Show All constraint commands. In order for a constraint to appear on the constraint bar when you use the Show or Show All constraint commands, the constraint type must be selected in this dialog box. You can also adjust the transparency of the constraint bars by entering a value or using the slider to adjust the value dynamically.
Showing and Deleting Constraints

The constraint bar for one object is shown in the following illustration. The illustration also shows that selecting a constraint highlights all geometry affected by the constraint. In this example, an equal constraint is applied to the two horizontal lines at the top of the sketch.

Showing Constraints on Multiple Objects

In the following illustration, the Show constraints command has been started. To show constraints on multiple objects, you must select them individually. Window selection, crossing, fence, or other selection options cannot be used with the Show constraints command. Alternatively, you could choose to use the Show All constraints command to view all constraints on all geometry in the drawing.
Constraint Bar Features

You can use the constraints bars in the following ways.

<table>
<thead>
<tr>
<th>Option</th>
<th>Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>Viewing constraints</td>
<td>On the constraints bar, click the constraint. The geometry referenced by the selected constraint is highlighted.</td>
</tr>
<tr>
<td>Deleting constraints</td>
<td>On the constraints bar, select the constraint symbol and press DELETE, or right-click the selected constraint and click Delete.</td>
</tr>
</tbody>
</table>

Show All Constraints

Using the Show All constraints command, you can see all of the constraints that are applied to objects in the drawing. When you select the Show All constraints command, constraint bars are displayed next to each object that has received a constraint. Pause over or select the constraint symbol to highlight the constrained geometry. Select the constraint symbol and press DELETE to remove the constraint.

The constraint bars are displayed next to each object that is constrained. Click and drag the bars to move them to another location.
Guidelines for Successful Constraining

Geometric constraints assist you in ensuring design intent by forcing objects in the drawing to behave a certain way or to maintain a certain position, angle, or shape. While the AutoConstrain command speeds up the process of applying constraints, you cannot depend on that command alone to apply constraints properly and constrain geometry as fully as needed.

Constraint Guidelines

The following list represents some guidelines to consider when you are placing constraints.

- **Determine dependencies**: During the design creation process, determine how geometric elements relate to each other and apply the appropriate geometric constraints.

- **Analyze automatically applied constraints**: After using the AutoConstrain command, you should determine whether any degrees of freedom remain on the geometry. If required, you can delete the automatically applied constraints and apply constraints to adjust the degrees of freedom to suit your design intent.

- **Use only needed constraints**: When you apply constraints to your geometry, take into account the design intent and the degrees of freedom that remain on the geometry. It is not necessary to fully constrain the design, but in some cases it is recommended. In other situations, you may be required to leave the design underconstrained. You can use the constraint-drag technique to see the remaining degrees of freedom on the geometry.

- **Stabilize shape before size**: Before you place parametric dimensions on your sketch objects, you should constrain the sketch to prevent the geometry from distorting. As you place the parametric dimensions, the sketch objects update to reflect the correct size. By stabilizing the geometry with constraints, you are able to predict the effect that the parametric dimensions have on the sketch geometry. If necessary, use the fix constraint to fix portions of the sketch.

- **Identify sketch elements that might change size**: When constraining sketches, take into account any features that may change as the design evolves. When you identify sketch features that may change, leave those features underconstrained. When a feature is left unconstrained, the feature can change as the digital prototype evolves.

- **Selection Order for Relational Geometric Constraints**: When manually applying relational geometric constraints, be aware of the importance of selection order. For example, when applying an equal constraint, the first object selected is the defining object and the second selection adjusts to match the first. This rule applies for all relational constraints.
Guideline Examples

The following list illustrates and describes some basic constraint guidelines.

**Determine dependencies:** In this illustration, the three short vertical line segments must remain perpendicular to the centerline, and the two diagonals must remain parallel to each other.

**Analyze automatically applied constraints:** In this illustration, the automatically applied constraints on the left side of the vertical line are being analyzed. The symbols (glyphs) on the constraint bars indicate which types of constraints have been applied. In this illustration, the perpendicular constraints are highlighted.
**Use only needed constraints:** In this illustration, the horizontal line has been intentionally left underconstrained. This enables the designer to adjust the position between the horizontal line and the centerline.

**Stabilize shape before size:** In this illustration, constraints are shown, but no dimensions appear on this sketch. The constraints have been added to stabilize the sketch shape before dimensions are applied to control its size.
Exercise: Create and Edit Constraints

In this exercise, you create geometric and dimensional constraints in a design and modify the design by editing constraints.

The completed exercise

Completing the Exercise
To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click Chapter 1: 2D Parametric Design. Click Exercise: Create and Edit Constraints.

1. Open C_Desk_Cst.dwg.
2. Verify the AutoConstrain settings:
   - On the Parametric tab, click Geometric panel > AutoConstrain.
   - Right-click anywhere in the graphics area. Click Settings.
   - Review the AutoConstrain settings and priority.
   - Click Cancel.

3. Using AutoConstrain, constrain the design geometry:
   - Window select all of the objects in your display.
   - Press ENTER.
4. Review the geometric constraints:
   - In the top view, observe the tangent constraints on the corners.
   - In the front and side view, observe the other constraints by selecting different constraint bars. The geometry associated with the constraint bar is highlighted when you select the constraint bar.

Note: Understanding geometric constraints helps you to predict how the geometry will behave when you add dimensional constraints, additional geometric constraints, or make changes to the geometry.
5. Add equal constraints to the desktop corner fillets:
   - On the Parametric tab, click Geometric panel > Equal.
   - For the first object, click the top left radius on the desktop (1).
   - For the second object, click the top right radius on the desktop (2).

6. Create two additional equal constraints. For each constraint, use corner 1 as the first object and corners 3 and 4 respectively as the second object.

7. Make the desktop symmetrical about the centerline construction line:
   - On the Parametric tab, click Geometric panel > Symmetric.
   - For first object, click the left vertical edge of the desktop (1).
   - For second object, click the right vertical edge of the desktop (2).
   - For the symmetry line, click the centerline (3).

   **Note:** Because of the colinear constraints between the front view and the top view, the geometry for the desktop in both views is symmetrical about the centerline.

8. Add symmetrical constraints to the access holes:
   - On the Parametric tab, click Geometric panel > Symmetric.
   - For the first object, click the circle on the left side of the desktop.
   - For the second object, click the circle on the right side of the desktop.
   - For the symmetry line, click the centerline.

9. On the Parametric tab, click Geometric panel > Hide All.
10. Using the Object option, add symmetrical constraints to the three lines in the front view as shown. For the second object, select the corresponding line on the right side of the view. For the symmetry line, use the centerline.

**Note:** If you start selecting at the top, then the middle, then the lower line, you receive an over-constrain error. See the next step.

11. Applying the constraint to the lower line produces the over-constrain warning because the lower line is colinear with the top line. By adding the symmetrical constraint to the top line, the lower line is constrained as well. Click Cancel to cancel the third symmetrical constraint.

12. Repeat the previous steps using two lines in the front view as shown. For the second object, select the corresponding line on the right side of the view. For the symmetry line, use the centerline.

13. Close all files. Do not save.
Lesson: Dimensional Constraints

This lesson describes how to create and use various types of dimensional constraints on your 2D geometry.

Using dimensional constraints on your geometry is a major aspect of creating parametric 2D designs. While geometric constraints stabilize the geometry and make it predictable, dimensional constraints size the geometry according to your design intent.

In the following illustration a profile containing both geometric and dimensional constraints is shown. The dimensional constraints have been configured to display using the Annotational constraint form.

Objectives

After completing this lesson, you will be able to:

- Describe the function of dimensional constraints.
- Create dimensional constraints.
- Describe the different forms of dimensional constraints.
- Describe best practices for applying dimensional constraints.
- Describe the Parameters Manager and how it can be used to manage drawing parameters.
About Dimensional Constraints

You create dimensional constraints by adding parametric dimensions to objects in a drawing. This is the final step in fully constraining your geometry. When you apply a parametric dimension to an object, the object changes size to reflect the value of the dimension.

Various types of dimensional constraints that you can apply to geometry are shown in the following illustration.

Definition of Dimensional Constraints

A dimensional constraint is a dimension that, when placed on geometry, determines the size, angle, or position of the geometry. Associative dimensions in nonparametric applications report the size, angle, or position of an object, whereas changes to dimensional constraints affect the object's size, angle, or position.
In the following illustration, when the dimension is placed, the initial value is 11.6271. When the value is changed, the width of the shape updates to reflect the new value. Note the d0 text in the dimension equation. This is the parameter name. Each time you place a dimensional constraint, a unique parameter name is automatically assigned. You can accept the default parameter names such as d0, d1, d2, etc..., or you can enter a more descriptive name such as width or depth.

Unlike nonparametric applications in which dimensions are simply numeric representations of the size of the geometry, in a parametric CAD application, dimensions are used to drive the size of the geometry. With this technology, you can quickly change a dimension and immediately see how the change affects the geometry.

**Dimensional Constraints**

The following illustration displays dimensional constraints that are used to control the size of objects in the drawing. Linear, radial, and diametric dimensions are applied to objects in the drawing and as a result they control the size of those objects. In this example, if you change the rad1 parameter from 2.5 to some other value, not only will the associated radius change, but because of geometric constraints applied to the objects, all of the small radii around the outside of the impeller drawing would change to reflect the new value. Similarly, a change to the d1 parameter from 30.00 to some other value would update the length of the line to which it has been applied, and the geometric constraints would force all the other lines to update thereby causing the entire impeller diameter to change.
Creating Dimensional Constraints

You use the DIMCONSTRAINT command to place dimensional constraints on objects in your drawing. You can produce linear, horizontal, vertical, aligned, angular, radial, and diametric dimensions with this single command. You can also use this command to convert existing associative dimensions to dimensional constraints.

Access

Command Line: DIMCONSTRAINT
Ribbon: Parametric tab > Dimensional panel > Linear/Horizontal/Vertical/Aligned/Radius/Diameter/Angular/Convert

Menu Bar: Parametric > Dimensional Constraints
Lesson: Dimensional Constraints

Command Access

Constraint Settings

Command Line: `CONSTRAINTSETTINGS`
Ribbon: Parametric tab > Dimensional Panel > Constraint Settings
Menu Bar: Parametric > Constraint Settings

Constraint Settings Dialog Box - Dimensional Tab

Use the options on the Dimensional tab of the Constraint Settings dialog box to control the display and behavior of dimensional constraints.
Select this option to display all dynamic dimensional constraints. This has the same effect as clicking Show Dynamic Constraints on the ribbon.

Select a dimension name format from the following options:
- Name - Displays the dimensions parameter name only.
- Value - Displays the dimensions value only.
- Name and Expression - Displays the dimensions parameter name and expression used.

Select this option to display a lock icon on annotational constraints. By default, dimensional constraints are displayed as dynamic constraints and always display the lock icon. You can change a dimensional constraint to an annotational constraint. This option only applies to those dimensional constraints that have been changed to the Annotational constraint form.

When this option is selected, dynamic dimensional constraints will appear temporarily for any object that is selected and has dimensional constraints applied. When the selection set is cleared, the dimensional constraints are hidden. This option is only applicable when dimensional constraints are not being shown globally.

Procedure: Applying Linear Dimensions

The following steps describe how to apply a linear parametric dimension:

1. On the ribbon, click Parametric tab > Dimensional panel > Linear.
2. Select the first and second points of the dimension, or press ENTER to select the object to dimension.
3. Position the dimension.
4. Enter a dimension value or expression. Press ENTER.

5. The geometry is updated to reflect the new value.

Procedure: Applying Radial/Diameter Dimensions

The following steps describe how to apply radial or diameter parametric dimensions.

1. On the ribbon, click Parametric tab > Dimensional panel > Diameter. Select an arc or circle.

2. Position the dimension.
3. Enter a dimension value or expression. Press ENTER.

4. The arc or circle geometry updates to reflect the new dimension.

Using Expressions in Dimensional Constraints

When you create dimensional constraints, the simplest type of expression is a value that you enter, in which case the dimension might read like $d_1=2.0$. However, it is possible to create more complex expressions for dimensional constraints. These expressions can contain the parameter names of other dimensional constraints or user parameters, and can include standard mathematical operations such as adding, subtracting, multiplication, division, and others.

In the following illustration, an existing parameter name, shapewidth, is used in a basic expression that multiplies its value by 1.25. To create mathematical expressions, enter their values as you create the dimensional constraint or double-click the dimensional constraint to edit the value and replace it with a mathematical expression.
Converting Standard Dimensions to Dimensional Constraints

It is possible to convert standard dimensions into dimensional constraints. This process is extremely useful for converting existing drawings to fully parametric and constrained drawings. If you choose to convert existing dimensions to dimensional constraints, you must also apply the appropriate geometric constraints. Failing to do so will cause the geometry to break and move in unpredictable directions.

Procedure: Converting Dimensions to Dimensional Constraints

The following steps give an overview for converting standard dimensions to dimensional constraints.

1. Start the DIMCONSTRAINT command and select an existing associative dimension.
2. If the dimension is a valid dimension that can be converted, you will be able to enter a value for the constraint parameter, or press ENTER to accept the current value. In this example, a new value is being entered.
3. The dimension is converted to a dimensional constraint and will appear using the dynamic constraint form.

Converting Dimensions On Unconstrained Geometry

It is not useful to merely convert associative dimensions to dimensional constraints alone. The geometry must also be properly constrained geometrically, otherwise any adjustments to a dimensional constraint breaks the geometry.
Adjusting Dimensional Constraint Forms

Dimensional constraints can be displayed as either dynamic constraints or annotational constraints. The dynamic constraint form is intended to be used for display purposes only and not intended for printing and/or annotation. The annotational constraint form is intended to be used when you need the dimensional constraints to also be used as annotated dimensions, so they appear correctly in your layouts.

In the following illustration, dimensional constraints are shown in both annotational constraint form as well as the default dynamic constraint form.

About the Dynamic Constraint Form

When you apply dimensional constraints to objects in your drawing, by default they are created and displayed using the dynamic constraint form. Intended for display only, the dynamic constraint form does not look like traditional dimensions. Current dimension styles have no effect on how dynamic dimensional constraints appear.
In the following illustration, a dynamic dimensional constraint is selected and its properties are displayed in the Properties palette. The properties available for dynamic dimensional constraints are minimal when compared to standard dimensions. Note there is no property for assigning a dimension style or adjusting properties such as text height, arrow heads, etc.

Using the Properties palette, you can change the dimension's properties and as a result change its type, name, expression, description, and text rotation. While all of the dimensions shown in this illustration are dynamic dimensional constraints, the diametric dimension associated with the circle has its Reference property set to Yes. The values for reference dimensions always appear in parentheses and the dimensions expression is read-only. Unlike standard dimensional constraints, when the Reference property is set to Yes, the dimension no longer controls the geometry, it only reports the size of the geometry to which it has been applied.
Dynamic Text Scaling

Dynamic dimensional constraints utilize automatic text scaling to ensure consistent display size of the dimension. In the following illustrations, the same geometry and dimensions are shown at different zoom magnifications. Regardless of the zoom magnification, dynamic dimensional constraints always appear the same size relative to the screen.

About the Annotational Constraint Form

You use the annotational constraint form when you need your dimensional constraint to serve both as parametric dimensions and annotative dimensions. When you set the constraint form to annotational, the dimensional constraint will have the same visual appearance as other dimensions in the drawing that use the same dimension style. Like regular dimensions, annotational dimensional constraints can be assigned a dimension style, and with the exception of the constraint related properties, they contain the same properties as regular dimensions.
In the following illustration, an annotative dimensional constraint is selected and the Properties palette is displayed. In addition to the constraint properties. Note the appearance of the other standard property groups such as misc., lines and arrows, and text.

Annotational vs. Annotative
Do not confuse *annotational dimensional constraints* with the annotative style that can be turned on for dimensions and other annotative objects. While annotational dimensional constraints can be set as *annotative* they are not the same thing.

Reference Dimensions
Each dynamic constraint has a reference property that can be set to Yes or No. By default this property is set to No, which enables the constraint to control the size of the geometry to which it has been applied. If the application of the dynamic constraint would cause the geometry to be over constrained, you are given the option of making the dynamic constraint a reference dimension. When this occurs, the Reference property for the dynamic constraint is set to Yes and thus prevents the dynamic constraint from controlling the size of geometry. As a reference dimension, it only reports the value of the geometry or points to which it has been applied.
In the following illustration, a reference dimension is shown (1) along with other dynamic constraints. Notice the Reference parameter is set to Yes indicating the selected dimension is a reference dimension. If you analyze the geometry you will see that the other four dimensions fully constrain the shape. No other dimensions are required to define this shape. The reference dimension simply reports the length of that side but cannot control the length. You could change this dimension to a standard dynamic constraint but you would first have to delete one of the other dimensions or change one of them to a reference dimension.
Procedure: Changing the Dimensional Constraint Form

The following steps give an overview for changing the constraint form of dimensional constraints.

1. Select the dimensions to adjust their constraint form.
2. Open the Properties palette, and select Annotational or Dynamic in the Constraint Form list.

Guidelines for Applying Dimensional Constraints

The process of applying dimensional constraints is essentially the same as applying regular dimensions with some key differences when it comes to entering values. Following these guidelines assures that you properly apply dimensions to your geometry.

Guidelines for Applying Dimensional Constraints

Consider the following guidelines when adding dimensional constraints to your drawing:

- Use geometric constraints when possible. For example, place a perpendicular constraint instead of an angle dimension of 90 degrees.
- Place large dimensions before small ones.
- Incorporate relationships between dimensions. For example, if two dimensions are supposed to be the same value, reference one dimension to the other. With this relationship, if the first dimension changes, the other dimension changes as well.
- Consider both dimensional and geometric constraints to meet the overall design intent.

These guidelines are not presented in any particular order; you do not need to apply all of them to the geometry in every drawing.
Example of Relationships Between Dimensions

Building relationships between dimensions captures your design intent. In this illustration, the intent is for the circle to always remain centered on the part. Building this dimensional relationship ensures that if the rectangle's width or length changes, the hole also moves in order to remain centered on the sketch. The dimension display is set to Name and Expression for clarity.

In the following illustration, the length is changed. Notice how the hole moved to maintain its centered position.
Without a dimensional relationship, a hole that was originally centered does not adjust if the length is changed.
Parameters Manager

As your parametric drawing grows in complexity, your list of parameters also grows. The Parameters Manager enables you to create, manage, and edit all of the parameters in the drawing. These include parameters that are created as you place dimensional constraints as well as any user parameters that you create as new parameters in the Parameters Manager.

Each dimensional constraint that you create is automatically named and stored as a parameter. Selecting the Parameters Manager button on the ribbon displays the Parameters Manager dialog box that lists all of the parameters in the current drawing.

Each dimensional constraint that you create is automatically named and stored as a parameter. Selecting the Parameters Manager button on the ribbon displays the Parameters Manager dialog box that lists all of the parameters in the current drawing. Notice the parameter names d1, d2, d3, and d4. These names are generated each time a dimension is placed. If you delete a dimension, its parameter is also deleted. You can rename the default dimension names and modify their values in the Parameters Manager.
Command Access

Parameters

Command Line: PARAMETERS
Ribbon: Parametric tab > Manage panel > Parameters Manager
Menu Bar: Parametric > Parameters Manager

Parameters Manager

The following options are available in the Parameters Manager:

1. Creates a new user parameter.
2. Deletes the selected parameters.
3. Filters the parameters in the list. You can show all parameters or only those parameters that are used in expressions.
4. Enter an expression for the parameter. You can enter a simple value or a mathematical expression such as Depth/2.
Process: Creating New Parameters

The following steps give an overview for creating new parameters in the Parameters Manager.

1. On the ribbon, click Parametric tab > Manage panel > Parameters Manager.
2. In the Parameters Manager, click New Parameter (1). The new parameter is created using the default user1 name (2).
3. Enter a new name, an expression, and/or a description.
Guidelines for Using Parameters

Consider the following guidelines when working with parameters.

- Consider renaming dimensional constraints to use names that are more descriptive.
- Parameter names are not case sensitive.
- Parameter names cannot begin with a number, contain spaces, or exceed 256 characters.
- Use the description column when possible to add brief descriptions to each parameter. This will help you and others interpret the intent of the parameter.
Exercise: Add Dimensional Constraints

In this exercise, you apply dimensional constraints to objects in a drawing. Using the techniques that you learned in this lesson, you apply a variety of dimensional constraints, adjust the display of those constraints, and create and then edit constraint parameters.

The completed exercise

1. Open C_Add-Dimensional-Constraints.dwg.

2. To set the dynamic constraint display format:
   - Click Parametric tab > Dimensional panel > Constraint Settings.
   - In the Constraint Settings dialog box, click the Dimensional tab and select Value in the Dimension Name Format list.
   - Click OK.

Completing the Exercise

To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click Chapter 1: 2D Parametric Design. Click Exercise: Add Dimensional Constraints.
3. To add a linear dimensional constraint:
   ■ On the Parametric tab, click Dimensional panel > Linear.
   ■ Select the lower left and right endpoints of the profile. Click to position as shown.
   ■ When prompted for the dimension value, enter 12. Press ENTER.

4. Create another linear dimensional constraint for the inside width as shown.

5. Change the units in the drawing to two decimal places.

6. Create a linear dimensional constraint on the left side of the profile as shown.

7. To add a radial dimensional constraint:
   ■ On the Parametric tab, click Dimensional panel > Radial.
   ■ Select the radius on the upper right corner of the profile. Position the dimension as shown.
   ■ For the radius value, enter .375. Press ENTER.

   Note: Equal constraints that were applied to the other three radius corners cause them all to update to the new value.
8. To rename a parameter while placing the dimension:
   ■ On the Parametric tab, click Dimensional panel > Linear.
   ■ Select the two points on top of the vertical lines as shown.
   ■ When prompted for the dimension value, replace the entire default value as shown.
   ■ Enter shapewidth=1.125. Press ENTER.

9. To add an angular dimensional constraint:
   ■ On the Parametric tab, click Dimensional panel > Angular.
   ■ Select the horizontal (1) and angled (2) lines. Position the dimension as shown.
   ■ For the angle, enter 30. Press ENTER.

10. To change the dimension display:
    ■ On the ribbon, click the arrow on the lower right corner of the Dimensional panel.
    ■ In the Constraint Settings dialog box, click the Dimensional tab.
    ■ In the Dimension Name Format list, select Name and Expression.
    ■ Clear the Show Lock Icon for Annotational Constraints option if it is selected.
    ■ Click OK.

11. To reference another parameter in a new dimensional constraint:
    ■ On the Parametric tab, click Dimensional panel > Linear.
    ■ Select the endpoints of the horizontal line. Position the dimension as shown.
    ■ For the width, enter shapewidth*1.25. Press ENTER.
12. To add a linear constraint the left side base of the part:
   - On the Parametric tab, click Dimensional panel > Linear.
   - Select the endpoints of the vertical line. Position the dimension as shown.
   - Enter 1.0 for the dimension value and press ENTER.

13. To use the Parameters Manager to edit a dimensional parameter:
   - On the Parametric tab, click Dimensional panel > Parameters Manager.
   - In the Parameters Manager, locate the d5 parameter.
   - In the Expression cell, enter shapewidth. Press ENTER.
   *Note:* The order of parameters may appear different from the image shown.

14. To create a new user parameter:
   - In the Parameters Manager, click Creates a New User Parameter.
   - For the parameter name, enter **InsideHeight**.
   - For the parameter expression, enter **2.25**.

15. To use the new parameter in a dimensional constraint:
   - Create a vertical linear dimensional constraint. Position it as shown.
   - For the value, enter **InsideHeight**. Press ENTER.
16. To change all the dimensions to the Annotational constraint form:
   - Select all the dimensional constraints.
   - Open the Properties palette. In the Constraint Form list, select Annotational.
   - Press ESC.

   Your dimensional constraints appear as shown.

![Dimensional Constraints](image)

17. With no objects selected, right-click anywhere in the graphics window. Click Parametric > Dimension Name Format > Value.

18. Start the DIMSTYLE command.
   - Modify the current dimension style to use an overall scale of 2. Set the Primary Units precision value to two decimal places.
   - Click OK.
   - Click Close.

19. Close all files. Do not save.
Lesson: Advanced Use Exercise - Mechanical

In this exercise, you use geometric and dimensional constraints to create 2D views of a rotary component.

Completing the Exercise
To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click Chapter 1: 2D Parametric Design. Click Exercise: Mechanical 2D Parametric Design.

Constrain the Geometry
1. Open M_Advanced-Use-Parametric-Design-Mechanical.dwg.

2. Use AutoConstrain to place the initial constraints on the geometry that will represent the front view.
   - On the Parametric tab, click Geometric panel > AutoConstrain.
   - Right-click anywhere in the graphics window, click Settings.
   - Click OK.
   - In the Constraint Settings dialog box, on the AutoConstrain tab, click Reset.
   - Using window crossing selection, select the circle and construction line geometry as shown and press ENTER.
3. Review the constraints that have been applied. There are tangent constraints (1), concentric constraints (2), coincident constraints (3), and a horizontal constraint (4).

4. To hide the constraints that have been created thus far, on the Parametric tab, click Geometric panel > Hide All.

5. AutoConstrain only established some of the constraints the geometry needs. To establish the relationship between the smaller circles and the larger ones, you apply additional tangent constraints:
   - On the Parametric tab, click Geometric panel > Tangent.
   - Select the small circle on the left.
   - Select the large, top center circle as shown.

6. Apply one more tangent constraint:
   - On the Parametric tab, click Geometric panel > Tangent.
   - Select the small circle on the left.
   - Select the large circle on the right as shown.

7. You now finish out the creation of the rotary design by trimming the larger circles using small circles as cutting edges.
   - On the Home tab, click Modify panel > Trim.
   - Trim the large circles as shown.

Notice what happened to all the constraints except one. The reason the constraints were removed is because when the circles were trimmed, their object types changed to arcs.
When an edit causes an object type to change, the constraints are removed.

8. To reapply the tangent constraints:
   - Repeat the tangent constraint tool and select the end of a large arc and the small circle it is currently touching.
   - Repeat for all ends of the large arcs.
   - On the Parametric tab, click Geometric panel > Concentric. Select the large arc and small circle it shares its center with. Reference the callouts in the following illustration. Constrain arc 1 to circle 1, arc 2 to circle 2, and arc 3 to circle 3.

9. To make all the small circles the same size, apply equal constraints:
   - On the Parametric tab, click Geometric panel > Equal.
   - Select the top circle, then select the lower left circle.
   - On the Parametric tab, click Geometric panel > Equal.
   - Select the lower left circle, then the lower right circle.
   - Position your cursor over one of the equal constraint bars to review the constraint relationships between the circles.

10. Next, you lock the horizontal construction line in place so that the geometry will adjust from this position when dimensional constraints are applied and changed later:
    - On the Parametric tab, click Geometric panel > Fix.
    - Select the lower horizontal construction line.
11. To hide all geometric constraints and provide some clarity on the screen:
   - On the Parametric tab, click Geometric panel > Hide All.

12. You need to constrain the centers of the small circles to the ends of the construction lines with a coincident constraint:
   - On the Home tab, click Geometric panel > Coincident.
   - Click a small circle, then select the near the end of one of the construction lines it is centered on.
   - Repeat for the other two small circles.
   Blue dots indicate the coincident constraints.

13. Set the size of the circles defining the smaller diameter of the rotary object. Place a diametric dimensional constraint:
   - On the Parametric tab, click Dimensional panel > Diameter.
   - Select the small top circle.
   - Position the dimensional constraint anywhere.
   - For the dimension text, enter 2. Press ENTER.
   You only need to apply one dimensional constraint because you applied equals constraints between the small circles earlier.

14. To define the base dimension size of the rotary object, you set the initial distance along the construction lines at the base of the object:
   - On the Home tab, click Dimensional panel > Linear.
   - Press ENTER to select the Object option.
   - Select the horizontal construction line.
   - Position the dimensional constraint as shown.
   - For the dimensional text value, enter 6. Press ENTER.
15. To test the geometry thus far to see if there are missing constraints:
   - Select the large lower arc to reveal its grips.
   - Click and drag on the arrow grips at each end of the arc to reposition them as shown.

   This reveals missing coincident constraints. While the arc is maintaining tangency, it should not be able to be moved off of the tangent point to the small circles. You will add the missing constraints in the next step.

16. To manually constrain the large arcs to the tangency points using a coincident constraint:
   - On the Parametric tab, click Geometric panel > Coincident.
   - Select the right end of the large arc.
   - Right-click anywhere in the graphics window, click Object.
   - Select the lower right small circle.

17. Repeat the Coincident constraint command option for the large arc and the lower left small circle.

   Note: When selecting the small circles, you have to use the Object option of the Coincident constraint tool, otherwise the constraint is applied to the center of the circle.
18. To clear up the screen, you hide the dimensional constraints and geometric constraints:
   - On the Parametric tab, click Dimensional panel > Show Dynamic Constraints.
   - On the Parametric tab, click Geometric panel > Hide All.

19. To complete adding coincident constraints between the large and small circles, you can automatically apply the coincident constraints to left and right side arcs. Use the AutoConstrain command and use crossing windows to select the two large arcs on the left and right and the three small circles.

20. Because the large arcs were close to the small circles, the coincident constraints are applied. They are indicated in the following illustration with blue squares.

21. Now, you can view the constraints in your final geometry. To show the dimensional constraints and geometric constraints:
   - On the Parametric tab, click Dimensional panel > Show Dynamic Constraints.
   - On the Parametric tab, click Geometric panel > Show All.

22. Save the drawing and proceed to the next exercise.

Work with Reference Dimensions and User Parameters

Next, you fully develop the rotary design. You work with reference dimensions and user parameters to capture the design intent. Finally, you use constraints to drive a side view of the rotary front view.

1. Open M_Advanced-Use-Parametric-Design-Mechanical.dwg if it is not already.
2. To add a reference dimension:
   - On the Parametric tab, click Dimensional panel > Radius.
   - Select the large arc on the left side of the part.
   - Position the dimension as shown.
   - Press ENTER to accept the default dimension value.
   - Because this constraint, would overconstrain the geometry, you are given a choice to create a reference dimension or reselect objects.
   - Click Create a Reference Dimension.

3. To change the reference status of the dimension you just created, you need to change one of the other dimensions to a reference dimension thereby releasing the dimensional constraint.
   - Select the diameter dimension on the top circle.
   - Right-click the dimension, click Properties.
   - In the Properties palette, select Yes in the Reference list.
   - Press ESC to clear the selection.

4. Select the radial dimension on the large arc that you created earlier:
   - In the Properties palette, select No in the Reference list.
   - Press ESC to clear the selection.
5. Next, you create a user parameter which you use to drive the size of the rotary. To create a new user parameter:
   - On the Parametric tab, click Manage panel > Parameters Manager.
   - In the Parameters Manager, click Creates a New User Parameter.
   - For the new user parameter, enter `RotaryArcRadius`.
   - In the Expression column, enter `9` for the `RotaryArcRadius` expression.

6. To adjust the parameter names:
   - Double-click the d1 parameter name and enter `CenterCenter`.
   - Double-click the dia1 parameter name and enter `BossDia`.

7. To use a user variable you created as an expression in another parameter:
   - Double-click the expression field for the rad1 parameter.
   - Enter `RotaryArcRadius`.
   - In the expression field for the `CenterCenter` parameter enter `7`.

8. To test the limits of your `RotaryArcRadius` constraint parameter, enter a value of `7` in the expression field. This will cause the Parameter Error dialog box to appear informing you that the value is invalid for the dimensional constraint. This occurs because of the way the geometry is constrained.
   - Click OK to close the dialog box.
   - In the `RotaryArcRadius` expression field enter `8`.
   - This value is accepted so you know the minimum size for the radius under the current constraint conditions is between 7 and 8.
9. Next, you use constraints to align geometry in the side view with the front view:
   - On the Parametric tab, click Geometric panel > AutoConstrain. Select the rectangle for the side view.
   - Press ENTER.
   - Using grips, resize the side view so that its height is similar to that of the front view.
   - Apply a tangent constraint between the top horizontal line in the side view and the top circle in the front view.
   - Apply a tangent constraint between the bottom horizontal line in the side view and the bottom arc in the front view.

10. Create the profile of the rotary bosses as shown. Then use the AutoConstrain command to constrain it to the main rectangle in the side view. Tip: Make sure to select all geometry in the side view.

Note: Depending on how you created the boss geometry, you may have to manually apply a collinear a constraint to the front vertical lines.
11. Place a tangent constraint to force the edges of the rotary bosses to line up with the circles in the front view. Then, apply linear dimensional constraints to the side view as shown.

12. To check your view alignment constraints:
   - In the Parameters Manager, change the RotaryArcRadius expression to 9.
   - Your view should appear as shown. Note: Dimensional and geometric constraints have been turned off for clarity.
   - Experiment with other values.

13. To change all dimension to annotational dimensions:
   - Select all dimensions on the drawing.
   - In the Properties palette, select Annotational in the Constraint Form list.
   - In the Properties palette, select Dimensions in the Layer list.
   - Press ESC to clear the selection.
   - Reposition the dimensions as shown if necessary.

14. To adjust how the dimensional constraints appear:
   - On the Parametric tab, click Dimensional panel > Constraint Settings, Dimensional (the arrow to the right of the panel name).
   - In the Constraint Settings dialog box, select Value in the Dimension Name Format list.
   - Clear the option to Show Lock Icon For Annotational Constraints.
   - Click OK.
15. To use a dimensional constraint to control the view spacing:
   - Apply a horizontal constraint parameter between the front and side views as shown.
   - Enter a value of 10.

16. To turn off the display of dynamic constraints, on the Parametric tab, click Dimensional panel > Show Dynamic Constraints.

17. Close all files. Do not save.
Lesson: Advanced Use Exercise - Architectural

In this exercise, you use parametric tools and techniques to size cabinets and position appliances and fixtures in a basic kitchen floor plan. You then use dynamic constraints and geometric constrains to adjust the kitchen’s size so that it complies with industry guidelines regarding the spacing between the most frequently used areas of a traditional kitchen.

1. Open I_Parametric-Kitchen.dwg or M_Parametric-Kitchen.dwg. Before continuing with this exercise, activate the 2D Drafting & Annotation workspace.

2. Some geometric constraints and dynamic constraints have been applied. To view these constraints:
   - On the Parametric tab, click Dimensional panel > Show Dynamic Constraints.
   - On the Parametric tab, click Geometric panel > Show All.

3. To hide the dynamic constraints and geometric constraints:
   - On the Parametric tab, click Dimensional panel > Show Dynamic Constraints.
   - On the Parametric tab, click Geometric panel > Hide All.

4. To begin creating the parametric plan view of the cabinet geometry, using standard lines and editing techniques, create the cabinet geometry as shown. Note when creating lines, do not be concerned about dimensions.

Completing the Exercise
To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click Chapter 1: 2D Parametric Design. Click Exercise: Architectural 2D Parametric Design.

Create a Parametric Kitchen
or accuracy. Make sure the endpoints are connected to other endpoints and existing lines.

5. Next, you will create user parameters to control the depth for the upper and lower cabinets. To create the custom user parameters:
   - If the Parameters Manager is not open, on the Parametric tab, click Manage panel > Parameters Manager.
   - In the Parameters Manager click Creates a New User Parameter.
   - For the user parameter name, enter **UpperCabDepth**.
   - For the UpperCabDepth expression, enter **18 (457)**.
   - Create another new user parameter named **LowerCabDepth** with an expression equal to **24 (610)**.

6. Now that the geometry is drawn and the required user parameters are created, the next step is to begin to constrain the geometry with both geometric constraints as well as dynamic constraints. To automatically constrain the objects:
   - On the Parametric tab, click Geometric panel > AutoConstrain.
   - Right-click anywhere in the graphics window, click Settings.
   - In the Constraint Settings dialog box, on the AutoConstrain tab, click Reset.
   - Select the lines previously drawn for the cabinets and the lines that represent the inside of the wall. It is important to select the wall lines, so that coincident constraints are applied to the walls.
   - Press ENTER.
7. Next, you begin to add dynamic constraints to the cabinet geometry. In some areas you use the new parameters previously created and in other areas you enter new values.
   - Zoom into the top left area of the kitchen floor plan.
   - On the Parametric tab, click Dimensional panel > Show Dynamic Constraints.
   - On the Parametric tab, click Dimensional panel > Linear.
   - Select the end points of the edge of the cabinet.
   - Position the dimension as shown.
   - For the dimension text, enter LowerCabDepth and press ENTER.

8. On the Parametric tab, click Dimensional panel > Linear.
   - Select the end points of the edge of the upper cabinet.
   - Position the dimension as shown.
   - For the dimension text, enter UpperCabDepth and press ENTER.

9. Repeat the previous steps to apply dynamic constraints to the lower right side of the cabinet lines. Notice how the geometry positions update to reflect the user parameter value.

10. In the upper right corner of the kitchen floor plan, there will be a cabinet placed at 45 degrees. To dimension and constrain this angle:
    - On the Parametric tab, click Dimensional panel > Angular.
    - Select the right side of the horizontal line for the upper cabinet.
    - Select the angled line of the upper cabinets.
    - Position the angular dynamic constraint as shown.
    - Enter 45 and press ENTER.
11. Continue to constrain the cabinet geometry for the upper cabinets in the upper left corner of the kitchen.
   - On the Parametric tab, click Dimensional panel > Linear.
   - Select the left end of the upper cabinets.
   - Select the right end of the upper cabinets.
   - Position the Linear dynamic constraint as shown.
   - For the dimension text enter 4' (1219) and press ENTER.

12. Next, you use geometric constraints to constrain the sink and appliances.
   - On the Parametric tab, click Geometric panel > Coincident.
   - Select the front of the cooking range block.
   - Select the midpoint of the vertical cabinet line.

   - Select the front of the cooking range block.
   - Select the midpoint of the vertical cabinet line.
14. Add a dynamic constraint on the lower horizontal wall to roughly position the nook for the refrigerator.
   - On the Parametric tab, click Dimensional panel > Linear.
   - Select the endpoints of the horizontal line as shown.
   - Position the dynamic constraint as shown.
   - For the dimension text, press ENTER to accept the default value.

15. To align the refrigerator with the walls surrounding its planned location, you use horizontal and vertical constraints between two points. When you use this method the two points selected are made to be vertical or horizontal, rather than the lines.
   - On the Parametric tab, click Geometric panel > Horizontal.
   - Right-click anywhere in the graphics window, click 2 Points.
   - Select near the middle of the refrigerator on the second line from the top.

   - Right-click anywhere in the graphics window, click 2 Points.
   - Select near the middle of the bottom line of the refrigerator.
**Lesson: Advanced Use Exercise - Architectural**

17. Place dynamic constraints on the wall behind the refrigerator and left side as shown (metric \(d_{16}=1067\), \(d_{17}=762\)).

18. Place a linear dynamic constraint as shown for the \(d_{18}\) dimension as shown. Then place an aligned dynamic constraint for the \(d_{19}\) dimension as shown. (metric \(d_{18}=1067\), \(d_{19}=457\)).

19. Using geometric and dimensional constraints, you have constrained the cabinet geometry and positioned appliances. In the next exercise, you use the power of parametrics to make quick and easy changes to the size of your kitchen floor plan.

**Use Dynamic Constraints to Adjust the Kitchen Floor Plan**

In this exercise you use geometric and dynamic constraints to adjust the kitchen floor plan based on the result of the kitchen triangle.

In the 1950's the University of Illinois developed a concept for planning the layout and size of traditional kitchens. This concept was referred to as the "work triangle" or "kitchen triangle" and it intended to provide a set of guidelines for spacing the 3 most frequently used areas of the kitchen. That is the sink, cooking surface, and refrigerator. This rule essentially says that when a triangle is drawn connecting each of the points in the kitchen, the perimeter should be no more than 26' (7925mm) with each side being at least 4' (1219mm) in length but no more than 9' (2743mm). Using the kitchen triangle, with geometric and dynamic constraints, you can adjust the size of your kitchen to adhere to the guidelines set forth in the work triangle concept.

1. Continue from the previous exercise or open `I_Parametric-Kitchen-Continued.dwg` or `M_Parametric-Kitchen-Continued.dwg`. 
2. Using the Polygon command, create a 3 sided polygon in the center of the kitchen as shown. Whether you use the Inscribed option or Circumscribed option is not important, nor is the size of the triangle important.

3. Using coincident constraints, constrain the triangle to the front of each appliance and sink as shown.

4. With the triangle constrained to each point in the kitchen, the next step is to determine how well the size of the triangle adheres to the guidelines suggested by the Kitchen Triangle concept. To measure the triangle:
   - On the Home tab, click Utilities panel > Area.
   - Press ENTER to use the Object option.
   - Select the triangle.
   - The triangle's area and perimeter are listed on the command line.
   - The perimeter should be listed at 26'-4 9/16" (8054mm).
5. Press ESC to clear the selection set and stop the Area command.

6. To check the lengths of the triangle sides, on the Status Bar, turn on Dynamic Input.
   - Select the triangle to reveal the grips.
   - Position your cursor over the grips to reveal the lengths of two sides of the triangle.

7. Now that we have determined that the perimeter and at least one side is beyond the recommended distances, you can use the dynamic constraints to adjust the size of the kitchen, while the geometric constrains force the geometry relationships to be maintained. Double-click the d3 constraint parameter (1) and enter 30 (762) as the new dimension text value. Press ENTER.

8. Double-click the d2 dynamic constraint and enter 8' (2438) for the dimension value and press ENTER.

9. On the Parametric tab, click Dimensional panel > Show Dynamic Constraints to hide the dynamic constraints and clear the screen.
10. To check the perimeter of the Kitchen Triangle:
   ■ On the Home tab, click Utilities panel > Area.
   ■ Press ENTER to use the Object option.
   ■ Select the triangle.

   The resulting perimeter appears on the command line and should be listed at 22'-3 9/16" (6811mm). This is now within the recommended guideline of being less than 26' (7925mm).

11. Press ESC to clear the selection set and stop the Area command.

12. Select the triangle to reveal the grips. Position your cursor over the grips to reveal the lengths of two sides of the triangle. Review the distances between the grips. All sides of the triangle are smaller than the recommended guideline of 9' (2743mm).
   ■ Position your cursor over the grips to reveal the lengths of two sides of the triangle.
   ■ Review the distances between the grips.

   All sides of the triangle are smaller than the recommended guideline of 9' (2743mm).

13. Close all files. Do not save changes.
In this chapter, you learned about the benefits and characteristics of creating parametric 2D geometry and how various types of dynamic constraints can be assigned to geometry enabling a greater amount of flexibility when editing your design. You also learned how to apply geometric and dimensional constraint parameters to stabilize geometry making it more predictable.

Having completed this chapter, you can:

- Describe the characteristics and benefits of designing using parametrics.
- Use geometric constraints to establish relationships between drawn objects.
- Apply dimensional constraints to 2D geometry.
- Use geometric and dimensional constraints to create 2D views of a component.
- Use parametric tools and techniques in a floor plan.